For support questions use our free support forum

Community Forum

Welcome to our Gamer Templates Forum

Community #2 Template Userpanel Bug

6 years 6 hours ago #3175 by dropkickz
Community #2 Template Userpanel Bug was created by dropkickz
Hallo,

ich hätte eine Frage bezüglich des Community #2 Templates für webspell 4.2.x.
Und zwar geht es um folgendes Problem: Bei einer neuen privaten Nachricht wird im Userpanel nichts angezeigt, also kein (1) neben dem Punkt "Nachrichtensystem".
In der Login.php ist allerdings der dafür verantwortliche Quelltextschnipsel vorhanden.
<?php

$_language->read_module('login');

if($loggedin) {
     $username='<a href="index.php?site=profile&amp;id='.$userID.'"><b>'.strip_tags(getnickname($userID)).'</b></a>';
     if(isanyadmin($userID)) $admin='&#8226; <a href="admin/admincenter.php" target="_blank">'.$_language->module['admin'].'</a><br />';
     else $admin='';
     if(isclanmember($userID) or iscashadmin($userID)) $cashbox='&#8226; <a href="index.php?site=cash_box">'.$_language->module['cash-box'].'</a><br />';
     else $cashbox='';

     $anz=getnewmessages($userID);
     if($anz) {
          $newmessages=' (<b>'.$anz.'</b>)';
     }
     else $newmessages='';

     if($getavatar = getavatar($userID)) $l_avatar='<img src="images/avatars/'.$getavatar.'" alt="Avatar" />';
     else $l_avatar=$_language->module['n_a'];


     eval ("\$logged = \"".gettemplate("logged")."\";");
     echo $logged;
}
else {
     //set sessiontest variable (checks if session works correctly)
     $_SESSION['ws_sessiontest'] = true;
     eval ("\$loginform = \"".gettemplate("login")."\";");
     echo $loginform;
}

?>

Ich weiß nicht, ob das Problem schon einmal diskutiert und eventuell behoben wurde. Ich weiß nur, dass ich das sehr gerne behoben hätte.

Vielen Dank schonmal für alle Antworten
MfG dropkickz
6 years 5 hours ago #3176 by dropkickz
Replied by dropkickz on topic Community #2 Template Userpanel Bug
Falls der Link zur Seite weiterhelfen sollte, was ich nicht glaube, da man registriert und eingeloggt sein muss um das Problem zu sehen, werde ich den hiermit nachreichen:

www.cod-com.bplaced.net
6 years 4 hours ago - 6 years 4 hours ago #3177 by Gamer-Templates
Replied by Gamer-Templates on topic Community #2 Template Userpanel Bug
Habe mir gerade mal deine Seite angeschaut. Wenn ich mir den Quelltext ansehe kann so einiges nicht funktionieren. Du hast 2x <head> und 2x <body>. Das kann so nicht funktionieren. Scheinbar hast du in den Dateien rumgefummelt. Ich kann dir nur empfehlen das Original Template einmal zu nehmen und dann zu testen ob die Anzeige geht. Dann sehen wir weiter!

Hier mal der Code der garnicht geht:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" " www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd ">
<html xmlns=" www.w3.org/1999/xhtml " xml:lang="en" lang="en">
<head>

<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<meta name="description" content="Clanpage using webSPELL 4 CMS" />
<meta name="author" content="webspell.org" />
<meta name="keywords" content="webspell, webspell4, clan, cms" />
<meta name="copyright" content="Copyright &copy; 2005 - 2009 by webspell.org" />
<meta name="generator" content="webSPELL" />

<!-- Head & Title include -->
<title>German Call of Duty Wii Community - Neuigkeiten</title>
<link href="tmp/rss.xml" rel="alternate" type="application/rss+xml" title="German Call of Duty Wii Community - RSS Feed" />
<!-- end Head & Title include -->

<!-- CSS INCLUDE -->
<link href="_stylesheet.css" rel="stylesheet" type="text/css" />
<link href="css/page-style.css" rel="stylesheet" type="text/css" />
<link rel="stylesheet" href="css/nivo-slider.css" type="text/css" media="screen" />

<!-- JAVASCRIPT INCLUDE -->
<script type="text/javascript" src="js/jquery-1.3.2.min.js"></script>
<script src="js/bbcode.js" language="jscript" type="text/javascript"></script>

<script type="text/javascript" src="js/jquery-1.4.3.min.js"></script>
<script type="text/javascript" src="js/jquery.nivo.slider.pack.js"></script>
<script type="text/javascript">
$(window).load(function() {
$('#slider').nivoSlider();
});
</script>
<link rel="stylesheet" href="css/prettyPhoto.css" type="text/css" media="screen" charset="utf-8" />
<link rel="stylesheet" href="css/logbox.css" type="text/css" media="screen" charset="utf-8" />
<script src="js/jquery.prettyPhoto.js" type="text/javascript" charset="utf-8"></script>

</head>
<body>

<div class="logbox_self"><a href="#2one_loginbox" rel="prettyPhoto" class="logbox">Login</a></div> <div class="logbox_line"></div>
<div id="main_container">
<div id="header"></div>

<div id="navi_leiste">
<div id="navi">
<ul>
<li class="platzhalter"><a href="#"></a></li>
<li class="home"><a href="index.php?site=home"></a></li>
<li class="about"><a href="index.php?site=news"></a></li>
<li class="port"><a href="index.php?site=squads"></a></li>
<li class="com"><a href="index.php?site=clanwars"></a></li>
<li class="down"><a href="index.php?site=forum"></a></li>
<li class="tut"><a href="index.php?site=calendar"></a></li>
</ul>
</div>
</div>
<div id="content">

<div align="center">
</div>
<p>
<table width="100%" border="0" cellspacing="0" cellpadding="0"><tr><td>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" " www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd ">
<html xmlns=" www.w3.org/1999/xhtml ">
<head>

<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
<title>Unbenanntes Dokument</title>
<script type="text/javascript" src="js/jquery-1.3.2.min.js"></script>
<script type="text/javascript" src="js/jquery-1.4.3.min.js"></script>
<script type="text/javascript" src="js/jquery.nivo.slider.pack.js"></script>
<script type="text/javascript">
$(window).load(function() {
$('#slider').nivoSlider();
});
</script>
<!-- 2ONE - LOGINBOX -->

<link rel="stylesheet" href="css/prettyPhoto.css" type="text/css" media="screen" charset="utf-8" />
<link rel="stylesheet" href="css/logbox.css" type="text/css" media="screen" charset="utf-8" />
<script src="js/jquery.prettyPhoto.js" type="text/javascript" charset="utf-8"></script>
<!-- 2ONE - LOGINBOX END -->
</head>
<body>

Hab die Fehler mal BOLD makiert!

MfG

No support via e-mail!
5 years 11 months ago #3178 by dropkickz
Replied by dropkickz on topic Community #2 Template Userpanel Bug
Dass was gemacht wurde, stimmt. Ich habe einige andere Grafiken für die Seite verwendet und an den Template Dateien lediglich die Menülinks umgestellt. Ein Kumpel hat mir zusätzlich noch in einige Dateien von webSpell selbst, die nicht von dem Template überschrieben werden, eine Funktion eingefügt, die bewirkt, dass Besucher keine Einträge hinterlassen können, da auf meiner letzten Page viel zu viel Spam trotz Captcha aufgetreten ist und aufgrund dessen deaktiviert wurde.

Der von Ihnen gepostete Quelltext sieht der Index.php ähnlich, aber weder in dieser noch in der News.php oder sonst irgendeiner php-Datei treten <head> oder <body> doppelt auf. Liegt vielleicht an einigen Include Befehlen.

Ich hab mir zu dem Ganzen auch noch einmal Gedanken gemacht und bin da eventuell etwas Relevantes gestoßen. Das Userpanel läuft über die Loginbox, die man auch für andere Templates seperat als Addon von den Jungs von http://www.2one-designs.de/ herunterladen und installieren kann. In besagten Community #2 Template ist eben dieses Addon schon eingebaut (siehe auch Ihren Quelltext). Sollte jetzt dieses Addon fehlerhaft sein, so ist es das Tempalte doch auch, oder sehe ich das falsch?