For Templates News & Updates follow us on Facebook

Community Forum

Welcome to our Gamer Templates Forum

Docman theme install problem

9 years 6 months ago #2111 by Zealand
Docman theme install problem was created by Zealand
I downloaded your adaptation of the old default Docman theme for Docman 1.5.2.

Being a .rar file it failed to install so I unpacked it and zipped it up. On trying to install the .zip version I got the Joomla message, "File ..../media/install_4b759ea827d4f/index.html does not exist!" I clicked Continue. The new theme now appeared in the list of themes in the backend. I selected it as the default.

On navigating to a Docman page in the frontend I get the error message, "Fatal error: require_once() [function.require]: Failed opening required ..../public_html/themeConfig.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in .../public_html/administrator/components/com_docman/classes/DOCMAN_theme.class.php on line 68".

Any ideas please?


Server side
Apache/2.2.11 (Unix)
MySQL version: 5.1.30
PHP version=5.2.5
Joomla! 1.5.15
Joomla configuration: All SEF settings=yes; Enable Web Services=Yes; Cache Settings=No
Docman v1.5.2

Client side
Vista, FF3.5.7

Please Log in or Create an account to join the conversation.

9 years 6 months ago #2112 by Gamer-Templates
Replied by Gamer-Templates on topic Docman theme install problem
Hello Zealand!

1) UNRAR DOWNLOAD!

2) Open FTP -> go to components/com_docman/themes/default -> open default and upload all my files and replace the old files (you can delete the content of the default folder first - NOT THE FOLDER!!!!)

3) Have Fun!

Kind regards...

No support via e-mail!

Please Log in or Create an account to join the conversation.

9 years 6 months ago #2154 by zealand
Replied by zealand on topic Docman theme install problem
Thanks for you quick reply. I followed your instructions in the subdomain test.devonshireprimary.org and the Docman pages in the front end now look fine. However, I need to change some of the theme settings so in the back end I go to the Installed Theme screen. This is what it looks like...

You will see that the database now has two themes!

If I try to change make the top one (Old DocMan Style - Modifikation by www.templates-directory.com ) the default I get the message "Theme not found". If I try to edit that theme's settings Joomla fails with "

Warning: file_get_contents(/home/adrianh/public_html/testthemeDetails.xml) [function.file-get-contents]: failed to open stream: No such file or directory in /home/adrianh/public_html/test/libraries/domit/xml_domit_lite_parser.php on line 1082

Warning: require(/home/adrianh/public_html/testthemeConfig.php) [function.require]: failed to open stream: No such file or directory in /home/adrianh/public_html/test/administrator/components/com_docman/includes/themes.php on line 114

Fatal error: require() [function.require]: Failed opening required '/home/adrianh/public_html/testthemeConfig.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/adrianh/public_html/test/administrator/components/com_docman/includes/themes.php on line 114
"

If I try to edit the current default (second line) and I get the usual screen as follows ...

Notice the heading is yours. The problem now is that when I save or apply the settings changes I get "Theme not found".

So I afraid we are not there yet. Please can you put me straight again?

Thanks

I will leave the screen shots at www.alexanderheeler.co.uk/templates-directory/ in place until all is resolved.

Please Log in or Create an account to join the conversation.

9 years 6 months ago - 9 years 6 months ago #2155 by Gamer-Templates
Replied by Gamer-Templates on topic Docman theme install problem
Your Joomla is in Legacy Modus.


We don´t support this Modus. All DOCman Themes are only for NATIV!

We never testing it in legacy mod. Sorry!

See the download description:

Template name DOCman 1.4 Theme NATIV
Template genre DOCman nativ

MfG

No support via e-mail!

Please Log in or Create an account to join the conversation.

9 years 6 months ago #2169 by zealand
Replied by zealand on topic Docman theme install problem
Thanks again for putting me straight. Docman 1.5.2 itself seems to work fine in legacy mode and I had assumed your theme would too. Now I know otherwise, I will stick with Docman 1.4 until there is a way forward since currently my template and one other extension require legacy mode.

I appreciate your work for the Joomla community.

Please Log in or Create an account to join the conversation.